Russian English German Ukrainian

Компьютерная помощь

(066) 72-00-654     (098) 44-74-068

г. Днепр

ж/м Левобережный-3

MikroTik: настройка IPTV

Чтобы настроить IPTV на роутерах MikroTik, сначала необходимо установить дополнительный пакет multicast.

  • Перейдите на оффициальный сайт MikroTik по ссылке http://www.mikrotik.com/download;
  • Определите, к какой серии относится ваш роутер, и версию операционной системы RouterOS, установленную на роутере. Если на сайте нет нужной версии, вам потребуется обновить операционную систему роутера до необходимой версии;
  • В разделе MIPSBE нажмите на ссылку напротив Extra Packages и необходимой версии RouterOS, чтобы скачать дополнительные пакеты;
  • Распакуйте скаченный архив с дополнительными пакетами;
  • Откройте в Winbox меню Files;
  • Перетащите из распакованной папки файл multicast-x.xx-mipsbe.npk в Winbox окно File List.
  • Перезагрузите роутер через меню System -> Reboot или через терминал командой /system reboot.

После перезагрузки в меню System -> Packages должен появиться модуль multicast.

Настройка IGMP Proxy

Откройте меню Routing -> IGMP Proxy и нажмите синий плюсик, чтобы указать на какой порт приходит IPTV. В выпадающем списке Interface выберите WAN порт, к которому подключен кабель интернет провайдера и поставьте галочку Upstream. В поле Alternative Subnets укажите подсеть стриммеров. Если вы не знаете данные подсети, то попробуйте указать: 10.0.0.0/8, 172.16.0.0/12 и 192.168.0.0/16.

Можно указать Alternative Subnets 0.0.0.0/0. Но так лучше не делать. Используйте 0.0.0.0/0 только если не смогли найти необходимую подсеть. После ввода параметров нажмите кнопку OK

Еще раз нажмите синий плюсик, чтобы указать на какие порты передавать IPTV. В выпадающем списке Interface выберите порт, на который нужно пробросить IPTV, и нажмите кнопку OK. В Interface желательно указывать один конкретный порт, чтобы не было проблем с производительностью роутера.

Нажмите кнопку Settings и поставьте галочку напротив Quick Liave. Это позволит быстро переключаться между каналами.

Настройка Firewall

Чтобы фаервол пропускал IPTV, необходимо добавить разрешающие правила. Откройте New Terminal.

Выполните в терминале следующие команды:

/ip firewall filter add action=accept chain=input comment="Allow IGMP" disabled=no in-interface=ether1 protocol=igmp
/ip firewall filter add action=accept chain=input comment="IPTV UDP incoming" disabled=no dst-port=1234 in-interface=ether1 protocol=udp
/ip firewall filter add action=accept chain=forward comment="IPTV UDP forwarding" disabled=no dst-port=1234 protocol=udp

ether1 - это интерфейс, на который приходит IPTV от провайдера. Если ваше имя отличается, укажите необходимое.

После этого откройте меню IP -> Firewall и перейдите на вкладку Filter Rules. Созданные правила перетяните кнопкой мыши вверх выше запрещающих.

Настройка Wi-Fi

Если вы транслируете IPTV по Wi-Fi, то необходимо выполнить следующие настройки.

  • Откройте меню Wireless.
  • Перейдите на вкладку Interfaces.
  • Откройте двойным щелчком беспроводной интерфейс wlan1.
  • Перейдите на вкладку Wireless.
  • Нажмите кнопку Advanced Mode.

Найдите параметр WMM Support и выберите enabled. Он включит поддержку Wi-Fi multimedia. Если у вас много клиентов, то его лучше не включать, поскольку один клиент может мультикастом съесть весь канал.

В параметре Multicast Helper выберите full. Это позволит отправлять мультикаст пакеты по MAC адресам клиентам, подключенным к Wi-Fi.

  • Сборка ПК для дома и офиса

  • Бесплатная диагностика

  • Гарантия

  • Самые низкие цены